weird subject in email notifications

Give us your feedback on the Forums Site, what forums we should add, and how we could be doing things better. (No product-related posts should be made here)

weird subject in email notifications

Postby pricerc » Mon May 18, 2020 11:01 am

any idea why most of my forum notifications now have a subject line something like this:

=?UTF-8?B?VG9waWMgcmVwbHkgbm90aWZpY2F0aW9uIC0gIkFsdGVybmF0aXZlIGxvZ2lu?= =?UTF-8?B?IGNyZWRlbnRpYWxzIGZvciBDb25uZWN0aW9uIFdpemFyZCI=?=

?
/Ryan

ERP Consultant,
Advanced ERP Limited, NZ
User avatar
pricerc
Jiwa Kohai
Jiwa Kohai
 
Posts: 230
Joined: Mon Aug 10, 2009 12:22 pm
Location: Auckland, NZ
Topics Solved: 6

Re: weird subject in email notifications

Postby Mike.Sheen » Mon Jun 15, 2020 6:23 pm

pricerc wrote:any idea why most of my forum notifications now have a subject line something like this:

=?UTF-8?B?VG9waWMgcmVwbHkgbm90aWZpY2F0aW9uIC0gIkFsdGVybmF0aXZlIGxvZ2lu?= =?UTF-8?B?IGNyZWRlbnRpYWxzIGZvciBDb25uZWN0aW9uIFdpemFyZCI=?=

?


I've noticed this as well - started happening a few months ago. We've not changed anything that I'm aware of, so I suspect it's something in Office 365 (which is what we use to email out from the forums software) which changed recently.

A subject of =?UTF-8?B?VG9waWMgcmVwbHkgbm90aWZpY2F0aW9uIC0gIkFsdGVybmF0aXZlIGxvZ2lu?= is a perfectly acceptable way for email subjects to contain non-ASCII characters and is compliant with RFC 1342.

The format is: =?charset?encoding?encoded-text?=

In our case we're sending the charset as UTF-8 and the encoding as B which represents Base 64 - so that means the encoded-text (VG9waWMgcmVwbHkgbm90aWZpY2F0aW9uIC0gIkFsdGVybmF0aXZlIGxvZ2lu) is the base 64 encoded subject - which decodes to:
Topic reply notification - "Alternative login


Maybe in a few months Office 365 will revert their change and things will go back to how they were.
Mike Sheen
Chief Software Engineer
Jiwa Financials

If I do answer your question to your satisfaction, please mark it as the post solving the topic so others with the same issue can readily identify the solution
User avatar
Mike.Sheen
Jiwa Shihan
Jiwa Shihan
 
Posts: 1674
Joined: Tue Feb 12, 2008 11:12 am
Location: North Sydney
Topics Solved: 522

Re: weird subject in email notifications

Postby pricerc » Tue Jun 30, 2020 4:10 pm

my forums mail goes to my GMail account, which is where I noticed this.

I decided to test forward one to my live.com account, and it gets the expected subject, even though the encoded subject is prepended with a 'FWD'.

To further add to the curiosity - my GMail 'sent' items has the subject displaying in English instead of Base64.

So I'd say it's just GMail not decoding correctly in my 'Forums' inbox...
/Ryan

ERP Consultant,
Advanced ERP Limited, NZ
User avatar
pricerc
Jiwa Kohai
Jiwa Kohai
 
Posts: 230
Joined: Mon Aug 10, 2009 12:22 pm
Location: Auckland, NZ
Topics Solved: 6


Return to Forums Site Feedback

Who is online

Users browsing this forum: No registered users and 1 guest